
CuteFTP�

for Microsoft
Windows®

95/98/ME/NT 4.0
and 2000

User�s Guide

by GlobalSCAPE, Inc.



2 CuteFTP Version 4  User�s Guide

Contents

Introduction ............................................................... 5
What is File Transfer Protocol? ................................................ 5
What is CuteFTP? .................................................................... 5
System Requirements ............................................................. 5
Installing ................................................................................... 5
Registration .............................................................................. 5
Uninstalling .............................................................................. 6

Starting CuteFTP ....................................................... 7
CuteFTP�s Main Screen ........................................................... 7
Using the Connection Wizard .................................................. 7
Connecting  to an Existing Site ................................................ 9
Using Quick Connect ............................................................... 9
Changing the Default Start-Up Window ................................... 9

Editing FTP Site Properties ...................................... 10
Adding a Site ............................................................................ 10
Removing a Site ....................................................................... 10
Site Manager Settings .............................................................. 11
Importing Sites From Old Versions of CuteFTP ...................... 13

Transferring Files with CuteFTP .............................. 14
Transferring Files ..................................................................... 14
Using the Queue to Transfer Files ........................................... 14
Stopping Transfers ................................................................... 14
Removing Queue Items ........................................................... 15
Resuming Transfers/Auto Reconnect ..................................... 15
Manually Getting a File ............................................................. 15
Setting the Transfer Type (ASCII/Binary) .................................. 15
Disconnecting, Reconnecting and Stopping Connections ..... 15
Spawning Sessions ................................................................. 15
Using Paste URL and Clipboard Monitoring ........................... 16
Custom Commands ................................................................ 16
Browser Integration .................................................................. 17

Working with CuteFTP MP3 and File Finder ........... 18
Using the MP3/File Finder ........................................................ 18
Searching for Files ................................................................... 20
Getting Files ............................................................................. 20
Adding to Site Manager ............................................................ 20
Ratio Sites ................................................................................ 21



3CuteFTP Version 4  User�s Guide

File and Folder Management .................................... 22
Filtering Files and Folders ....................................................... 22
Filter Options ............................................................................ 22
Wildcard Masks ........................................................................ 24
Searching for Files on an FTP Server ...................................... 24
Viewing, Editing, and Executing Files ...................................... 24
Deleting, Renaming and Moving Files ..................................... 25
Creating, Renaming and Deleting Folders ............................. 25
Changing Attributes of Files and Folders ................................ 25
Directory Information and Statistics ......................................... 26
Comparing Local and Remote Directories ............................. 26
Site-to-Site Transfers ............................................................... 26
Saving Remote/Local Download Paths ................................... 26
Using Bookmarks .................................................................... 27
Getting Links as Files .............................................................. 27
Symbolic Links ......................................................................... 27
Toggling Panes and the Toolbar. ............................................. 27
Long Listing and Short Listing ................................................. 28
Showing File Details ................................................................ 28
Sorting the File Listing ............................................................. 28
Printing a Directory Listing ....................................................... 28
Refreshing the Directory Listing .............................................. 28

Automating Functions .............................................. 29
Macro Scripting ......................................................................... 29
Automatically Renaming Transferred Files ............................. 30
Scheduling File Transfers ........................................................ 30

CuteFTP Settings ...................................................... 31
Advanced Settings .................................................................... 31
Auto Renaming Settings .......................................................... 32
Browser  Integration ................................................................. 32
Connection Settings ................................................................. 33
Connection � ASCII/Binary ....................................................... 33
Connection � DUN/LAN ........................................................... 33
Connection � Firewall .............................................................. 34
Connection � Index Files .......................................................... 35
Connection � Log ..................................................................... 36
Connection � Smart Keep Alive ................................................ 36
Connection � Socks ................................................................. 37
Connection � WarFTP Specific ................................................. 37
Directory Navigation Settings ................................................... 37
Display  Settings ...................................................................... 38
Display � Colors ....................................................................... 39
Display � Fonts ......................................................................... 39
Display � Sound ....................................................................... 39
Helper Applications .................................................................. 39
Prompts .................................................................................... 40



4 CuteFTP Version 4  User�s Guide

Troubleshooting ........................................................ 41
Connection Problems .............................................................. 41
Frequently Asked Questions .................................................... 42
Technical Support and Services .............................................. 47

Shortcut Keys ............................................................ 48
Index ........................................................................... 49



5CuteFTP Version 4  User�s Guide

Introduction

What is File Transfer Protocol?
File Transfer Protocol (FTP) has been used almost exclusively on UNIX
workstations and mainframes for many years to transfer files between remote
computer systems.  Early FTP software used a command-line interface difficult
for some beginners to work with.  As the Internet grew in popularity, new
standards appeared (Gopher, WWW) providing more user-friendly interfaces.
However, FTP remains the popular choice among computer professionals.

What is CuteFTP?
CuteFTP is a Windows-based File Transfer Protocol (FTP) application that
allows you to utilize the capabilities of FTP without having to know all the details
of the protocol itself.  CuteFTP simplifies FTP by offering a user-friendly
Windows interface instead of a cumbersome command-line utility.  CuteFTP
gives novice PC users the ability to upload, download, and edit files on remote
FTP servers around the world.

Installation

System Requirements
� Any PC running Windows 95, 98, ME, Windows NT 4.0 or 2000.
� At least 16 MB of free memory, 3-5 MB of free hard disk
   space and a CD-ROM drive.
� A connection to the Internet.

Installing
To install from CD-ROM:  Place the CuteFTP CD in your CD-ROM drive.
Installation begins automatically.  Follow the on-screen instructions.

If your CD-ROM drive does not support automatic installation:  Place the
CuteFTP CD in your CD-ROM drive.  Double-click the My Computer icon
located on the Desktop.  Double-click the CD-ROM drive icon.  Double-click the
setup.exe icon.  Follow the on-screen instructions.

Registration
During the installation process, CuteFTP prompts you for a serial number.  If
you purchased CuteFTP directly from GlobalSCAPE, the serial number is
located on your invoice.  If you purchased from a retailer, it�s on the CD jacket or
the cover of this manual.

Manual Registration:
Use manual registration if server or Internet connection errors occur during the
online registration. Choose Help>Enter your serial number from the menu bar.
Complete the required information. Click Register.
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For another method of manual registration, open the Server Connection Error
dialog box.  Click the Manual Registration button. Complete any missing
information on the form (click each field name and begin typing).
Click the Copy to Clipboard button on the Manual Registration dialog box.
Send the e-mail to support@globalscape.com. Press the Control-V keys to
copy the clipboard contents (registration information) to the body of your e-mail.
Send the e-mail.  The GlobalSCAPE support team will reply with instructions
and a file needed to complete the successful registration of your program.

Uninstalling
The uninstall function removes the program CuteFTP from your PC.  It also
removes the CuteFTP icon from your Desktop.  However, configured sites still
remain after uninstalling and then reinstalling CuteFTP.  To uninstall CuteFTP,
click the Start>Settings>Control Panel.  Then select Add/Remove Programs.
Choose CuteFTP from the list and click the Add/Remove button.  Follow the on-
screen instructions.



7CuteFTP Version 4  User�s Guide

Starting CuteFTP
From the Start menu, choose Programs> GlobalSCAPE>CuteFTP>CuteFTP, or
double-click the desktop CuteFTP icon.

CuteFTP�s Main Screen
The main screen is used to transfer files to and from remote servers and is
divided into four panes:  an upper pane, two center panes, and a lower pane.
The center panes represent files available on local and remote drives, much
like Windows Explorer.
Upper window (Log window). The log window displays the commands you

send and the server�s responses.  CuteFTP logs this information to inform
you of completed transactions or assist in troubleshooting.

Center left window (Local window). The local window displays the selected
directory from your hard drive.

Center right window (Remote window). The remote window displays the files
and directories of the remote server.

Lower window (Queue window). The queue window shows the files currently
being transferred to the server.  It also serves as temporary storage for files
you wish to transfer at a later time.

Using the Connection Wizard
Select File>Connection Wizard from the menu bar.  The Connection Wizard
breaks the site setup process into easy-to-understand screens.
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1. Choose your ISP.
Predefined:  Predefined sites include all pertinent data needed to connect to

your service provider.  The Wizard includes basic information.  Users must
still provide a user ID and password to access a directory or file.  Select a
predefined site from the pop-up menu.

Other: Select Other to log into sites not listed.  Obtain login information from
your ISP or FTP Administrator.

2. Enter a Site Label.
This screen only appears when Other is selected at the beginning of the
Connection Wizard.  Type in a word or words that describe your site.  This label
is shown on your Site Manager screen.

3. Enter the Host Address (hostname or IP address).
This appears only when Other is selected at the beginning of the Connection
Wizard.  Type in the address of your server.  If you do not know the address,
contact the administrator of the site or your Internet Service Provider.

4. Enter user ID and password.
User IDs and passwords are provided by your Internet Service Provider.  Both
are case sensitive.

The following options are also available:
Anonymous Login.  Individual servers frequently limit user access to informa-

tion and  file transfer actions after an Anonymous Login.  NOTE:  If the log
on process fails because  the site is set  up for a user ID and password, a
prompt will appear soliciting this information.

Mask Password.  If selected, asterisks will appear as each letter of the pass-
word is typed.  Once Mask Password is selected and you begin typing your
password, you cannot deselect Mask Password to see letters instead of
asterisks.

5. Specify a Default Local Directory.
This optional field is part of the Connection Wizard.  Leave this field blank if you
do not wish to specify a default directory.  Enter information in this field if you
wish to move to a specific local directory when you connect to the site being
added.

6.  Click in the box next to one or both of the options below.
Connect to this site automatically.  If you want to go to your new site when

starting CuteFTP, select this item.

Add to right click shell integration.  This choice enables you to upload a file or
folder to a site by right-clicking items on the Windows Desktop or Explorer.



9CuteFTP Version 4  User�s Guide

Connecting  to an Existing Site
Use the Site Manager to connect to an existing site.  Select File>Site Manager
from the menu bar and select a site from the list in the Site Manager window.
Click the Connect button and CuteFTP connects to the site.

Using Quick Connect
This feature is useful for one-time connections.  Users have the option of
adding the session to Site Manager before terminating the session.

To perform a Quick Connect, select File>Quick Connect from the menu bar, or
click the Quick Connect lightning bolt icon on the tool bar.  Enter the site
address in the Host field, and a User Name and Password if necessary. Click
the lightning bolt to connect.  To add the site to the Site Manager, click
Commands>Session>Add Session to Site Manager before breaking the
connection.

Changing the Default Start-Up Window
CuteFTP allows you to decide which window to display when the program
opens:  Site Manager, Default Wizard Site, Quick Connect or Nothing. To
change the default start up window, go to the Connection section of the Edit>
Settings window.  Choose the desired start-up window from the Settings
dialog under Upon startup launch.
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Editing FTP Site Properties

Start the Site Manager by clicking on the Site Manager icon on the tool bar or
by choosing File>Site Manager on the menu bar. Secure access to your sites
by choosing Security>Set Password from the Site Manager menu bar.
CuteFTP will ask for a password before connecting to any site in the Site
Manager when this option is enabled.

Adding a Site
Use the Connection Wizard to take you through the steps of creating a site or
do the following:

1. From the menu bar, select File>Site Manager.
2. Select an existing folder from the directory tree on the left or create a new

folder for the site.
To create a folder, select File>New Folder from within the Site Manager.

3. Click the New button. Enter a name for your site in the Label for site field.
4. Enter the FTP server address in the FTP Host Address field.  The address

is obtained from the Service Provider hosting your web pages.  NOTE:  Do
not  type in ftp:// or http://  before the server address.

5. Enter the user ID in the FTP Site User Name field.  The user ID is provided
by your Service Provider and is case sensitive.

6. Enter the password in the FTP Site Password field.  The password is
provided by your Service Provider and is case sensitive.

7. If the site requires a port other than 21 (nearly all FTP sites use 21) to
establish a connection, enter it in the FTP site connection port field.

8. Select the Login Type. Normal is used if a username and password are
required; use Anonymous to connect to anonymous FTP sites. The Double
option is used when a dual login is required.  An anonymous login will
automatically be supplied to the server and then a second login will occur
using the supplied user name and password.

9. To connect to your new site, highlight the site name in the left window and
push the Connect button.

Editing a Site
Existing sites may be modified at any time.  To edit a site, open the Site
Manager, which is located by default as an icon on the far left side of
theToolbar.  Select a site from the list on the left of the window.  You can then
modify its basic settings in the right-hand side of the window.  More settings are
available by clicking the Edit button.  See Site Manager Settings for a complete
description.

Removing a Site
To remove a site from the Site Manager, select the site from the list and then
select Edit>Delete from the Site Manager menu bar.
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Site Manager Settings

By clicking the Edit button in this dialog, users may set each of the following
settings.

Under the General tab:

Host Type.  By default, CuteFTP will automatically detect which type of server
(host) it is connecting to.  Use the drop down menu to select a server type if
problems occur connecting to a specific host.

Default Remote Directory/ Default Local Directory. Specify the initial remote/
local directory (path).

Site Comments.  Use this field to type comments about the FTP site. This has
no effect on the connection to the site.

Enable Filter.  Activates Filtering. Click Filter... to edit defined filters.  See
Filtering Files & Folders for more information.
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PASV Mode: CuteFTP uses PASV Mode to initiate all connections while the
server only waits for requests.  When active, this feature helps avoid
conflicts with the security system.  This feature is active by default.

Enable Firewall Access: This field is active by default.  CuteFTP uses the
settings defined in the Firewall section of the Edit>Settings window.

Under the Advanced tab:

Connection Retries/Delay between retries.  The Connection Retries field
specifies how many times CuteFTP should attempt to connect to the
server. The Delay between retries field tells CuteFTP how long to wait after
an unsuccessful attempt before trying to reconnect.

Use AutoRename Scheme.  Active by default, this feature renames file
extensions before uploading to the server.  Renaming file extensions is
helpful if the extension on the local side is different than the extension
required by the server or remote side.  Refer to the Automatically
Renaming Transferred Files section for more details.

Preserve Case, Force Uppercase, Force Lowercase.  CuteFTP can �force� a
file to upload in lower, upper, or preserved case.  This is helpful if you
created files with mixed case on your system, but need them to be upper or
lower case on your server.

Use as default login site. When checked, this site becomes the default site that
CuteFTP automatically connects to, if you have the Edit>Settings>
Connection>Upon Startup Launch feature set  to Connect to Default Site.

Max Safe Index Size. This field specifies the size (in kilobytes) of the largest
index file to load without prompting. Setting this parameter to zero will
cause CuteFTP to prompt you for all index files.  Setting it to 32000
effectively disables any prompting.  NOTE: It is not advisable to set this
parameter too high because there might be multi-directory index files on
the sites that CuteFTP can�t handle.  The default is 100 kb.

Auto-Cache Index Files.  Inactive by default, CuteFTP searches for index files
and automatically loads them in memory.

Simple Directory Listing. CuteFTP will display file names only in directory
listing.

Enable Smart Keep Alive. Check to have Smart Keep Alive maintain a
connection automatically.  Refer to the Smart Keep Alive section for more
details.

Use Logical Parent Directory. Active by default, this feature specifies the
previously visited directory as the parent directory rather than the actual
physical parent.  It is useful on sites with many inter-directory links.

Save Session Log to file. Save Log files for this FTP site.

Add Site to shell integration. This function allows you to upload a file or folder
from the Windows desktop or Explorer to a designated site in CuteFTP.
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From Windows Explorer, locate your file or folder, place your mouse pointer
over the name, right-click to get a menu, then left-click on CuteFTP.  Click
the site you wish the file or folder to upload to or click Connection Wizard
to set up a new site. If checked, this site will appear in the right-click menu.

Cache site �resume� status. If checked, CuteFTP will remember that the site
either does or does not support resuming transfers, which can speed up
connection times.

Transfer Type. Select ASCII or Binary to force those transfer modes, or select
AutoDetect to have CuteFTP determine transfer types for you.

Check file size on download.  When CuteFTP checks file size, it compares the
server�s original file size to the size of the downloaded file to ensure that
the transfer is complete and accurate.  This setting allows users to specify
one of four choices.

Use Global Settings is on by default.  This means that users can adjust
their Global Settings in order to alter this choice for every site with this
specification.

On.  With this choice selected, CuteFTP will check download size for every
file after downloading.

Off.  CuteFTP will not check file size.

Auto.  CuteFTP will check file size if the server permits this action.

Importing Sites From Old Versions of CuteFTP
CuteFTP�s Site Manager now houses its data in a file called sm.dat, located in
the CuteFTP directory. Older versions of CuteFTP use tree.dat (before 2.5) or
smdata.dat (2.5 to 3.5). Importing the Site Manager files will allow you to
access your old sites.

Import your old sites into CuteFTP by clicking on the Import button in the Site
Manager and then locating your tree.dat file. If you have installed version 2.6 or
greater, then look for smdata.dat in the import directory located under the
CuteFTP directory. Once you find the tree.dat or smdata.dat file,  either double
click on it or highlight it and choose  Open in order to import the previous Site
Manager information. The sites now appear in your Site Manager.

If the tree.dat file that you imported was also in the same directory where the
bookmark.dat was, then even your old bookmarks will be imported.
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Transferring Files with CuteFTP

Transferring Files
Once you are connected to a remote server, there are many ways to start file
transfers:

Drag-and-Drop.  Select the file you want to transfer.  Using your left mouse
button, �grab� the highlighted file, drag the file to the opposite window, and
drop the file anywhere in that window (including folders).

Menu/Toolbar.  Select the files you want to transfer.  Select Transfer>Upload or
Transfer>Download from the menu bar, or click the Upload or Download
buttons on the tool bar.

Double-click the File.  Highlight the file to transfer and double-click.  NOTE: The
Double-Click Action feature must be set to Transfer for this to work.

Using Queue to Transfer.  Highlight the file you want to transfer and drag it to
the Queue window or select Transfer>Queue>Add to Queue.  Click
Transfer>Transfer Queue to transfer the file.

Right-click Context Menu. Select the file, right-click, then select Import or
Export from the context menu.

Windows Desktop or Windows Explorer.  Right-click on the file or folder you
wish to transfer, then choose CuteFTP Upload.  The FTP sites you have
specified in the Site Manager for use in Windows Explorer or Desktop will
be listed.  Choose the desired site and CuteFTP will begin uploading.  If
you are not connected to the remote server you may still use Shell
Integration. To enable Shell Integration, go to the Advanced section of the
Edit>Settings section.  Click Enable Right-Click Shell Integration to
activate the feature.

Cut or Copy & Paste.  Select a file and choose Edit>Cut to move the file or
Edit>Copy to copy the file.  Then, select the opposite pane and choose
Edit>Paste to transfer the file.

Using the Queue to Transfer Files
Files may be added to the queue using most of the methods under the
Transferring Files section, and then batch transferred at a later date by clicking
on the Transfer Queue button on the Toolbar.  Queue functions can be
accessed by using the right-click menu in the queue window.

Stopping Transfers
CuteFTP uses persistent transfer to resume and complete transfer requests
stopped by a broken connection.  Users must disable the persistent transfer
feature to permanently stop a transfer.  To disable persistent transfers, deselect
Enable Persistent Downloading in the Connection section of the Edit>Settings
window.

To stop a transfer, either select Transfer>Stop from the menu bar, press the
Stop button on the tool bar, or press F9.
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Removing Queue Items
To remove queued items, select them in the queue window and choose
Transfer>Queue>Remove from Queue from the menu bar, or right-click on the
files to remove and choose Remove from Queue.

Resuming Transfers/Auto Reconnect
If disconnected while downloading or uploading a file, CuteFTP will
automatically reconnect and resend until the transfer is successful.  To disable
this function, see Stopping Transfers above.

If Connect to the Internet using a LAN or Connect to the Internet using a
modem is not activated, you  must manually reconnect to the site where the
transfer was broken.  CuteFTP sees that you are replacing an existing file and it
will ask to �Resume�, �Overwrite�, or �Skip�.  Choose Overwrite if you are
replacing the file.  Choose Resume to complete a broken transfer, or Skip to
cancel the operation.

Manually Getting a File
Use this function to download a specific file if you know its exact directory
location.  Select Manual Get from the Transfer menu, and enter the full path
and file name to download.

Setting the Transfer Type (ASCII/Binary)
CuteFTP is programmed to automatically select the proper transfer type (Auto).
To manually specify a file transfer type, select Edit>Settings from the menu bar
and go to the ASCII/Binary section.  Choose the radio button for the transfer
type you prefer.

Disconnecting, Reconnecting and Stopping Connections
To disconnect.  Select File>Disconnect from the menu bar or click the

Disconnect icon on the tool bar, or press Shift+F4.

To Reconnect.  Select File>Reconnect.   If �Connect to the Internet Using a
LAN� or �Connect to the Internet via Modem� is activated, CuteFTP will
automatically reconnect in the event of a broken session.  See Dial-Up
Networking.  NOTE: CuteFTP can resume broken transfers only if the FTP
server allows it.

To Stop a Connection or Transfer.  Either select Transfer>Stop,  press the
Stop button on the tool bar, or press F9.

Spawning Sessions
CuteFTP will allow you to open multiple sessions.  This is useful when you are
downloading a file from one site and want to browse or download a file from
another site simultaneously.  You will still have access to all configured sites
when multiple sessions are open.  To launch another session of CuteFTP with
the same site open, select Commands>Session>Spawn Current Session
from the menu bar.
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Using Paste URL and Clipboard Monitoring
Connect to a site or download a file by pasting a URL into CuteFTP.  To connect
via URL, select a URL in any Windows application and copy it to the clipboard
using Edit>Copy.  Return to CuteFTP and select File>Paste URL from the menu
bar or press Control-P.  CuteFTP will automatically connect to the site or
download the file.

The monitor clipboard function is very handy when used with your web browser.
Instead of using your web browser (which may not resume transfers) to
download FTP links, copy the links and let CuteFTP perform the transfer.  Refer
to Monitor Clipboard in the CuteFTP Settings for instructions on enabling
clipboard monitoring.

CuteFTP supports all standard and many nonstandard URL formats.

Custom Commands
Users may choose from pre-defined commands or create custom commands
to communicate with a server.   ISPs normally distribute to all subscribers a
custom commands file (COMMANDS.DAT) for their Web server.

Using a pre-defined command.
1.  Select Commands>Custom Commands from the menu bar.
2.  Select a custom command from the list.

Adding a custom command
1. Select Commands>Custom Commands>Define from the menu bar.
2. Type a name identifier in the Label field.
3. Enter the command text in the Command Text field.  The command text is

the actual FTP command sent to the server.  It can contain any character,
and one or more macros.

4. Enter an optional hot key in the Hot Key field.  The command can be
executed using Control+Shift plus this hot key.

5. Click the Add button.

Command text macro expressions
%[ prompt ]. When this macro is encountered, CuteFTP displays a prompt

dialog box with an input field.  The user can then type any text in the input
field, which will be inserted into the actual command text in place of the
macro.  �Prompt� can be any text, not containing [ ] (square brackets).  It will
be used as a title for the prompt dialog box.

%f. This macro will be substituted by the name of the file currently selected in
the remote browser.  If more than one file is selected, the command will be
repeated for each file.

%%. A single % character.
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NOTE: The Show Server�s Response switch specifies whether CuteFTP should
display the server�s response to the command.  If set, a dialog box will pop up
containing a command-response sequence for each command executed.  The
Hot Key box is a keyboard accelerator assigned to the command.

Common Command Examples
SITE CHMOD %[New Access Mask] %f:  This command will prompt the user for

a �New Access Mask� and use it for each selected file. For instance, if user
enters �=rwx� at the prompt, and FILEA.TXT, FILEB.TXT and FILEC.TXT files
are selected, the following sequence of commands will be sent to the
server:

SITE CHMOD =rwx FILEA.TXT
SITE CHMOD =rwx FILEB.TXT
SITE CHMOD =rwx FILEC.TXT

SITE INDEX %[Search Text]: This command will prompt for �Search Text� and
send a single command to the server. For instance, if a user enters
�CuteFTP� at the prompt, the following command will be sent to the server:
SITE INDEX CuteFTP.

Browser Integration
CuteFTP�s Browser Integration feature intercepts FTP URLs accessed via
your browser and uses CuteFTP technology to complete the file transfer.  The
characteristics of this feature can be modified by choosing Edit>Settings>
Browser Integration.
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Working with CuteFTP MP3 and File Finder

Using the MP3/File Finder

The Cute MP3/File Finder makes searching the Internet for MP3s and other
files easy.  It has been recently updated; by using the latest search engines,
CuteFTP finds reliable links to files and automates the downloading process.

Locate the CuteMP3/File Finder by choosing File>Cute MP3/File Search.

File Name Window: (Enter a file, song, or group name):  Type in the name of
the file to find.

Limit Returns To:  Type in the maximum number of file matches that you want
returned by a search.

Found:  This window shows the number of matches.

File Type:  Choose which file type to find (MP3 or other files).

Search Engines:  CuteFTP relies on external search engines for MP3 and file
searches.  Choose the search engine(s) you want to use in the Search
Engines box.  Select or deselect a search engine using the check box next
to its name.
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Search button:  Searches for your selected file and returns the results.  A small
x by the search engine�s name indicates that a search is in progress, a
large X indicates a completed search.

Continue button:  This allows you to continue your search if you hit the Stop
button.

Add to Queue button:  Select files and add them to your queue to download
later.  Highlight the files you want and click the Add to Queue button.

Smart Get button: This is a powerful tool for automating the downloading
process.  Select a file and press the Smart Get button.  It will highlight
every file with the same file name and put them into the queue.  CuteFTP
will then try to download the first instance of the file.  If it encounters an
error, it will go on to the next file in the queue until the file is downloaded.

Help button:  This button provides information on using MP3 and File Search.

Proxy Button:  This option is important if you have a proxy server you use to
access the Internet.  The dialog box which appears gives you the options:
Do not use,  Use system settings and Use following configuration.  Do
not use is the default setting.  Use system settings is, basically, an order
to your CuteFTP to autodetect any settings currently on your computer.
Use following configuration allows you to specify your HTTP proxy server
and port.

Name:  This column shows the list of file names found by your search.

Host/Port:  Displays the address and port of the found file�s server.

Path/Size:  This displays the path on the server where the file exists, and the
file�s size.

Delay:  Indicates what kind of a delay exists on a particular server.  A higher
delay number generally means a slower site.  Try to get files from a server
with a lower delay time.

Queue:  Flags which files have been added to the queue window.

User:  Shows the User ID required to log on to that server.

Passwd:  This column shows you the password required to log on to the
server.

Source:  Thiis column displays the search engine source of the file.

Sorting:  Search results can be organized by clicking on the title bar in each
column.  For example, clicking on the Name bar organizes the results
alphabetically by name.  Clicking it again reverts the listing back to its
previous order.

Right-Click Options:  These options appear in the context menu when you
right-click one of the files found by the search.

Import:  While in the remote pane, select an item and download it.

Export:  While in the local pane,  select an item to upload it.
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Add to Queue:  Adds files to your queue to be downloaded later.

Delete: Deletes the selected file.

Delete All: Deletes all files listed in the search results window.

Connect:  Connects automatically to the server and downloads the
selected file.

Find:  Performs more flexible searches and downloads.  A dialog box
appears that allows you to perform more specific or more general
searches on the search results. Type the search term (no wildcards)
in the Find what: field.  Use the filters found on the left to further narrow
your search.  Use the Find Next button to scroll through every found file
or click the Mark All button to select all of them.

Smart Get:  This functions the same as the Smart Get button.

Searching for Files
To search for MP3s or files, select File>Cute MP3/File Search� from the menu
or click the tool bar globe icon.  Enter a name to search for in the Enter a file,
song, or group name: field and optionally enter a maximum number of returns
in the Limit returns to:  field.  Select the file type in the File Type area and check
the search engines to use.  Press Search to begin.  To cancel the search,
press Stop.

Getting Files
Once files are found, you have several downloading options.

Connect:  To get a single file on the list, right-click on the file name and choose
Connect from the menu.

Add to Queue: You can select files and add them to your queue to be
downloaded later.  Simply highlight the files you want, and click the Add to
Queue button.

Smart Get: Select a file and press the Smart Get button.

Verify File Size. With this choice, you can verify the size of the files you plan to
retrieve.  NOTE:  This option should not be used with some MVS servers.

Adding to Site Manager
If you find an FTP site in your queue that you would like to access again, add it
to the Site Manager at any time by right-clicking in the queue window and
choosing Add session to SM, or selecting Commands>Session>Add session
to Site Manager� from the CuteFTP menu bar.
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Ratio Sites
Many FTP sites are run as �ratio sites�.  Operating under a type of file trading
system, these sites do not allow downloads until you have uploaded a file or
files.  Credits are issued for the uploaded files which, in turn, enables
downloading from the site.

The error message �Insufficient credit for download � upload first� is issued
from a ratio site.  Refer to the index or text file on that site for instructions on
uploading to their server.

If searching for MP3s using the Smart Get feature, you may have trouble with
ratio sites. If Smart Get receives a ratio site error, it will move on to the next
server without giving you a chance to upload.

If you find a ratio server that you would like to download from while using the
Smart Get feature, you will need to press the stop button (or F9) during the
transfer.  Right-click on the file in queue window and choose Reset Status.
Next, highlight the file on the server you want to connect to and click the Queue
Transfer button on the Toolbar. You will probably receive another warning about
permissions; just press OK if one appears.

Now, you need to upload a file to this ratio site, and they probably only allow
uploads in a certain directory.  Look for an upload directory on the site.  Go to
the root directory by pressing the yellow Up Directory Button.

Although you will probably be successful using Smart Get to download files,
you may need to use other download options in the Cute MP3/File Finder.
These options are defined under Getting Files in the Cute MP3/File Finder
section of this manual.

Use the queue feature of CuteFTP to make uploading to ratio sites easier and
eliminate problems downloading files.  Add some files to the queue and
upload them upon connecting to the ratio site.  Consult the administrator of the
ratio site if you have problems with uploading or receiving credits.
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File and Folder Management

Filtering Files and Folders
CuteFTP can display a portion of a directory, hiding unwanted files temporarily.
Filtering works by matching each filename in a directory against a user-defined
Wildcard mask.

Adding/Removing a filter
       From the menu bar, click Edit>Filter.  To have this filter apply to only one

site, edit the site in Site Manager and select the Filter button.  Select the
Filter Mask or Filter NOT Mask tab.  Enter the filter definition in the top box
and click the Add button.  The filter information should appear in the bottom
box.  To remove a filter, select the definition from the list and press the
Remove button.

Filter Mask:  Any files matching the parameters defined in the Filter Mask tab
will be displayed. For instance, if you wish to see only JPEG files, you
would add the filter *.jpg.

Filter NOT Mask:  Files matching filters listed in the Filter Not Mask tab will not
be displayed.  This allows you to eliminate any group of files without
affecting others. Adding a filter such as *.jpg would cause CuteFTP to no
longer display JPEG files.

Filter Options
The Edit>Filter window�s Options tab has several selections you may use to
help with filtering files.

Apply filters to local directory listing: This option applies filters to the local
directory listing.



23CuteFTP Version 4  User�s Guide

Apply filters to remote directory listing:  This option applies filters to files
displayed in the remote directory listing.

Apply filters to folder name(s):  This choice causes directories to be affected
by the filters.

Let CuteFTP do the filtering (recommended): CuteFTP applies the filters you
have defined.

Enable remote filters (Server applied filter):  CuteFTP sends a command
containing the filter to the server. You must define filters to be sent in the
box below this option.  NOTE:  You can now use local and server filtering
simultaneously.

Apply filters to uploads/downloads: CuteFTP filters files during uploads or
downloads. Useful when transferring directories.

Apply filters to site-to-site transfer:  Filters are enabled when transferring files
using Site-to-Site Transfers.

Case sensitive filtering:  Filters will be case sensitive, i.e. *.JPG is a different
filter than *.jpg.

Displaying Hidden Files: You can display hidden files on servers using a
special filter command.  When configuring your filter, select Enable remote
filters (Server applied filter).  Type in-rtaF next to this field. Your listing
command should now be LIST�rtaF, which allows display of hidden files.

Selecting file groups using filters: Select Edit>Group Select from the menu
bar.  Enter a Wildcard expression in the Filter Mask field.  Select Mask
Directories if you would like to filter directories as well as files.  Select
Remove Selection to clear currently selected items before selecting
masked items.  Press OK and the filter selection is performed on the
currently selected pane. Some examples are included below.

Task: Select all GIF, but not HTML files.
Operation: Use Group Select, specify *.GIF as

filter mask, press OK.

Task: Select all files, except HTML files.
Operation: Use Group Select with * as a filter

mask, then use Deselect Group with *.HTML as a filter mask.

Task: Select GIF and JPG files, but not HTML,
TXT, DOC, WPG files.

Operation Use Group Select with *.GIF as a
mask. Use Group Select again with *.JPG mask and the
Remove selection check-box cleared.

To invert the selected files (highlights files not matching the filter):  From the
menu bar, click Edit>Invert Selection.

To deselect a group of files:  From the menu bar, click Edit>Group Deselect.
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Wildcard Masks
Wildcard masks are patterns of special characters used to filter file names.
When a Wildcard mask is matched against a file name, the two patterns are
compared, letter-by-letter, from left to right until a mismatch occurs. If all the
characters in both patterns compare positively, the file name matches the
Wildcard Mask.

A Wildcard Mask can contain the following characters:

? Will match any single character (i.e. ? will match a,b,c,1,2,etc...)

* Will match any sequence of characters (including no characters at all),
terminated by the next character in the mask. (i.e. *a will match cutea,
wwwa, zzza, a etc.).

[ ] Will match any character in the character set enclosed in the brackets.
This can also be a range of characters (i.e. [A-Z] ).

If the opening bracket is followed by !, matches any character NOT in the set
(i.e. [abc] will match a, b or c only. [!abc] will match any character except a, b or
c).

Wildcard Mask Examples

Mask: Will Match:
* all files
*.bmp sample.bmp, xyz.bmp, but not sample.gif
x?z xyz, xaz, but not xyy
a[xyz]c axc, ayc, azc, but not abc
a[!xyz]c abc, adc, afc etc, but not axc
a[a-c]d aad, abd, acd, but not axd

Searching for Files on an FTP Server
Use this feature to search for file names and extensions in the current directory.
NOTE: Wildcards will not work.  The first entry found is highlighted.  Subsequent
entries can be found with the Find Next command (F3).

To find a file, select Edit>Find from the menu bar.  Enter the file name or
extension to find, and press OK.  Select Edit>Find Next to find the next matching
entry.  CuteFTP will display  No More Matches Found when all matching entries
have been highlighted.

Viewing, Editing, and Executing Files
View.  Located on the tool bar, this command opens the highlighted file (either

on the local or remote drive) in your text file viewer.  Select a text file viewer
by going to Edit>Settings>Helper Applications.
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Edit.  Select an editor program in Edit>Settings>Helper Applications.  Users
may also choose to leave the field blank.  To edit a file, right-click on the file
name and select Edit.  If you use CuteHTML as your editor, you will need to
initiate the transfer to upload any changes to the remote site; otherwise,
you will be presented with a dialog box asking you to upload the changes.

Execute.  Click Commands>File Actions>Execute to launch the highlighted
file, or right-click on the file and select Execute from the pop-up menu.

Deleting, Renaming and Moving Files
You may access these commands from the from the menu bar under
Commands>Directory or from the right-click menu.

Move...:  Highlight the file(s), select Move and enter the new path.

Rename...:  Highlight the files, select Rename and enter a new name for the
file.

Delete:  Select the file(s), choose Delete (or press the Delete key).  Files on the
local hard drive will be relocated to the Recycle Bin.  Any other files will be
permanently deleted from the FTP server.

Creating, Renaming and Deleting Folders
You may access the following commands from the menu bar under
Commands>Directory or from the right-click menu.

Make New Dir...: creates a new folder.
Rename: renames an existing folder.
Delete: deletes an existing folder.

Changing Attributes of Files and Folders
From the menu bar, use Commands>File Actions>CHMOD to change the
attributes of a file or folder on the server. In the Change Attributes dialog box,
select the Read, Write, or Execute options for each group (Owner, Group and
Public) or type in the corresponding CHMOD command in the box.

Below is a brief description of CHMOD permissions and how they work:

CHMOD�s permission mask is a three-digit number.  Each digit
defines the permission for a different user of the file.  The first digit
defines the permission for the owner, the second digit defines the
permissions for the group and the third digit defines the permissions
for everyone else (referred to by CuteFTP as public).  Each digit works
the same for each group of users: the owner, group, and public.  What
you set for one digit has no effect on the other two digits.  Each digit is
made up of the three Read, Write, and Execute permissions. The
Read permission value is 4, the Write permission value is 2, and the
Execute permission value is 1.  These three numbers are added
together to get the permissions for a file.  If you want a file to be
readable and not writable or executable, set its permission to 4.  This
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works the same for Write and Execute.  Executable only files have a
permission of 1.  If you want a file to have Read and Write
permissions, add the Read and Write values together (4+2) and you
get 6 � the permissions setting for Read and Write.  If you want the
file to be Read, Write, and Execute, use the value 7 (4+2+1). Do this for
each of the three permission groups and you get a valid CHMOD
mask.  For example, if you want your file to have Read, Write, and
Execute permissions (4+2+1) for yourself; Read and Execute (4+1) for
your group; and Execute (1) only for everyone else, you would set the
file permissions to 751.

Directory Information and Statistics
CuteFTP maintains information regarding your directories and files in an easily
accessible feature called Directory Information.  Directory Information displays
paths, number of files, combined file size, and other information for all files and
selected files.  To view the directory information, select
Commands>Directory>Directory Information from the menu bar.

Comparing Local and Remote Directories
Contents of local and remote directories can be compared using the Compare
Directories command.  To use Compare Directories, navigate to the desired
directory in both the local and remote panes.  Then, select Commands>
Directory>Compare Directories from the menu bar.  Select the desired
comparison options:

Ignore Letter Case.  Will not look at capitalization during comparison.
Compare Sizes.  Will look at file size during comparison.
Compare Dates.  Will look at file dates during comparison.

Files that match will NOT be highlighted.

Site-to-Site Transfers
CuteFTP is capable of transferring files from one remote server to another.
Some servers do not allow this style of transfer; if you�re having difficulty getting
this feature to function properly please contact the administrator of the FTP site
to see if Site-to-Site Transfers are supported.  To perform a Site-to-Site
transfer, connect to the first remote site and choose Window>New CuteFTP
Window to launch another instance of CuteFTP.  Connect to the second site in
the new window.  Drag and drop the desired file from one window to the other.

Saving Remote/Local Download Paths
To save the current local or remote directory path information to the FTP Edit
Site screen, select Commands>Session>Save remote path to SM or Save
local path to SM.  The current path will be saved in the Initial Remote (or Local)
Directory field in the Site Manager�s Edit Site> Settings>Site
Properties>General tab.

Example: You login anonymously to ftp.cuteftp.com and by default start out in
the root directory. You then double-click the pub folder and then the CuteFTP
folder which puts you in /pub/CuteFTP. Click Commands>Session>Save
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Remote Path to SM. Then /pub/CuteFTP is saved into the Initial Remote
Directory field under Edit Site in the Site Manager. The next time you connect to
this site, you will be automatically placed into the /pub/CuteFTP directory.

Using Bookmarks
CuteFTP uses bookmarks to mark local and/or remote directories so you can
quickly access them at a later date.  Only bookmarks specific to an open site
will be available for use.  There are two ways to add bookmarks.

To bookmark a directory automatically, navigate your way to the desired
directory.  Select Bookmarks>Add from the menu bar.  Choose a name for the
bookmark.  To use the bookmark, connect to the site you bookmarked.  Select
Bookmarks from the menu bar and choose the desired bookmark from the
pull-down menu.

To add a bookmark manually, right-click a site in the Site Manager and choose
Advanced>Add Path Bookmark...  Name the bookmark and enter a local and
remote directory on the right-hand side of the window.

To edit or remove existing bookmarks, select Bookmarks>Edit from the menu
bar.  Select a bookmark and click the Edit or Remove button.

Getting Links as Files
This command directs CuteFTP to get a directory link as a file so that the user
does not have to change directories to get files.  From the menu bar, click on
Commands>File Actions>Get Link as File.  The contents of the linked directory
will begin downloading.

Symbolic Links
This UNIX-specific option asks the server to resolve symbolic links to either a
file or a directory.  This option can cause problems with non-UNIX servers.  If
you are having trouble displaying a list of files located on the server, try
deselecting this option by going to the Directory Navigation section of the
Edit>Settings window.  Select the Do not resolve links radio button.

Toggling Panes and the Toolbar.
To switch focus from the local to remote pane or vice versa, select
Window>Switch Browser from the menu bar, or press Tab.

To toggle the display of the local or remote panes, press F6 or F7 respectively,
or choose Window>Toggle Local/Remote from the menu bar.

To toggle the display of the queue window, press F10 or select Window>Toggle
Queue.

To resize panes, position the cursor over the border of two panes until the
cursor becomes a bar with two arrows pointing away from it.  Click and
drag to resize the pane.

To hide the tool bar, select View>Toolbar from the menu bar.  Select the same
item again to re-enable the tool bar.
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Long Listing and Short Listing
File names are displayed in the local and remote panes of the main CuteFTP
window. To change the view, select a pane and choose either Long Listing or
Short Listing from the View menu.  Short listings display file name only.  Long
listings display: name, size, time/date, attributes, and description.

Showing File Details
Users can customize the level of detail displayed when using long listing
mode.  To customize the long listing display, select a pane and choose File
Details from the View menu.  All available display options are selected by
default.  To remove an item from the long listing display, deselect the
corresponding box.

Sorting the File Listing
In long listing mode, you can sort the listing according to contents of any listed
column.  Clicking a column header toggles between ascending and
descending sort order.  Alternatively, by selecting Sorting from the View menu
you can select the desired sort order and type.

Printing a Directory Listing
Select File>Print  from the menu bar to print the directory listing of the currently
selected pane.

Refreshing the Directory Listing
Although CuteFTP automatically refreshes the Directory Listing after certain file
management operations, you may choose to do a manual refresh for very large
directory listings.    To manually refresh the selected pane, select Refresh from
the View menu or press F5.  Automatic refreshing can be disabled from the
Directory Navigation section of the Edit>Settings window.  Deselect the Auto-
Refresh Remote Directory check box.
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Automating Functions

Macro Scripting
Macros save time by recording keystrokes and commands for routines that you
might perform frequently.  The following instructions cover recording and
executing macros.

Recording a macro for automated playback:  Click on
Commands>Macros>Start Recording from the menu bar.  Every
command and keystroke will be saved from this point.  Connect to your site
and perform the tasks you wish to record.  Click Commands>Macro>Stop
Recording to stop recording and then save the script.

NOTE:  Commands that can be recorded are limited to transfers (including
wildcards), uploads, downloads, deletions, and directory changes.  To have the
macro shut down CuteFTP after the transfer executes, edit the script file that was
created and add the word SHUTDOWN to the last line.

Executing a macro from within CuteFTP:  Select Commands>Macros>
Execute Macro from the menu bar.  Choose the macro file to execute and
click OK.

Executing a macro from the command line:  Use the following command to
automatically launch CuteFTP and execute your macro:

�[path to CuteFTP executable]� Macro=[path to saved macro]
NOTE: Quotes required for paths containing spaces.
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Example:
�C:\Program Files\GlobalSCAPE\CuteFTP\CutFTP32.exe�
Macro=c:\Scripts\DailyUpload.mcr

Automatically Renaming Transferred Files
CuteFTP can rename file extensions during upload (i.e. converting .htm to
.html).  To enable this feature, go to the Auto Renaming section of the
Edit>Settings window.  Click Add and enter the local file extension in the Local
field.  Enter the desired new extension in the Remote field.  Now, go to the Site
Manager.  Choose Edit� for each site the auto-rename scheme should apply
to.  Switch to the Advanced tab and enable Use Auto-Rename Scheme. You
must have the Use Auto-Rename Scheme check box selected in your FTP Site
Edit screen for this to work.

Scheduling File Transfers
CuteFTP has the capability to automate file transfers using the built-in
scheduler. This is useful for transferring a number of files on a daily basis.

Adding queue files to the scheduler:
1. Select the files to transfer and add them to the queue.
2. Select Transfer>Queue>Save Queue from the menu bar.
3. Select Transfer>Schedule Transfers... from the menu bar and check

Enable Scheduler.  (Check Show countdown timer to display a
countdown until download time)

4. Click Add Queue File and select the queue file saved in step 2.
5. Select a date and time to initiate the queue transfer.

Rescheduling/Removing queued files:  In order to reschedule or remove
queued files, select Transfer> Schedule Transfers... from the menu bar.
Select the queue file to change.  Click Delete to cancel the queued item, or
Edit� to reschedule.

Scheduling currently queued files:  If you have already queued several files
you may select Schedule current queue in the Scheduler dialog box. Enter
the date and time to initiate the transfer. Click Reschedule to change the
date and time.  NOTE: The current queue must be scheduled to run before
any other scheduled queues.

Disabling the scheduler:  To postpone any queued file transfers, uncheck
Enable Scheduler in the scheduler dialog box
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CuteFTP Settings

To configure CuteFTP, select Settings from the Edit menu.  The Settings
window displays a list of configuration categories on the left-hand side, and the
settings themselves on the right.

Advanced Settings
Monitor Clipboard for FTP URLs.  Activates CuteFTP�s URL parsing feature.

Any time an FTP URL is copied onto the Windows Clipboard, CuteFTP will
automatically connect to the site and begin downloading the target file.
This feature assumes an anonymous login. Note that the monitor
clipboard function does not currently support redirected URLs.

Minimize to System Tray.  When minimized, CuteFTP places a small icon in
the System Tray rather than a standard Task Bar button.

Auto-check for version updates.  The Auto Update feature keeps CuteFTP
current by automatically downloading the latest new features and bug fixes.
CuteFTP connects to the GlobalSCAPE website and retrieves a newer
version if available.

Save Quick Connect History.  When enabled, CuteFTP stores recently
accessed Quick Connect sites in the Quick Connect Bar�s pull-down
menu.  If deselected, CuteFTP will clear these entries upon exit.

Delete to Recycle Bin.  To make CuteFTP permanently delete files, deselect
Delete to Recycle Bin.

Use REST before APPE when resuming.  The REST (restore) command is a
more efficient but less widely supported way to resume file uploads.  If
REST is rejected, CuteFTP uses APPE (append), the default, to resume.
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Treat leading zeros in IPs as octal numbers. This setting alerts CuteFTP to
treat leading zeros as a cue to octal (base eight) programming.  Decimal
(base ten)  programming dominates the field at this time, so octal
programming should not affect the majority of transfers.

Check file size on download. CuteFTP will compare the file size on the file you
have downloaded with the file on the server to ensure an accurate transfer.

Retry last XXX bytes when resuming transfers.  If you are worried about
corruption as the result of a broken transfer, specify the point at which
(number of bytes) CuteFTP will resume downloading.  For example, a
transfer might break at 420 bytes.  If you had specified 100 bytes for this
option, CuteFTP would resume the transfer at 320 instead of 421 bytes.

Receive/Send Buffer.  This shows the size in bytes of transmission buffers.
Larger values may increase performance at the cost of higher RAM usage.
Generally, there is no need to modify these values.

Enable right-click shell integration.  Allows file transfers from Windows
Explorer or Desktop.  Refer to Transferring Files with CuteFTPsection for
more information.

Prompt for directory when doing right-click transfers.  CuteFTP asks for a
destination directory rather than using the default directory.

Auto Renaming Settings
This section configures CuteFTP�s automatic renaming ability.  For more
information on configuration and use of auto renaming, refer to the
Automatically Renaming Transferred Files section.

Browser  Integration
CuteFTP�s Browser Integration feature intercepts FTP URLs accessed via
your browser and uses CuteFTP technology to complete the file transfer.  This
means that CuteFTP becomes the default tool for handling FTP links from both
your browser and operating system.  The characteristics of this feature can be
modified by choosing Browser Integration from the Settings dialogue box.

The following is a list of the check boxes that appear in the Browser Integra-
tion dialog box accessed through General Settings. These selections allow
you to choose how CuteFTP will treat FTP URLs:

Monitor FTP links (Web browser and in Windows program).  This option
allows CuteFTP to intercept FTP URLs accessed via your browser.

Open each FTP link in a new session of CuteFTP.  A new FTP session will be
launched each time you access an FTP URL.

Prompt for file name before downloading.  CuteFTP will open a Save As
dialog box to ask you for a file name and path before you download a file.

Close CuteFTP after completing a download. CuteFTP will close itself down
after a transfer is complete.  This keeps the application in the background.
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Connection Settings
E-Mail Address.  Anonymous FTP servers require an email address for

identification purposes.  You may enter whatever you want here, but some
servers will check the address for validity and refuse your connection if it�s
invalid.

Upon startup launch.  Perform this task immediately after CuteFTP launches.

Connection retries & Retry delay.  Attempt network connections this many
times, waiting the desired number of seconds between attempts.

Always check and store �resume transfer capability� for each site.  Site
Manager can remember whether or not each site supports resuming
broken transfers.  This will speed up connections since CuteFTP won�t
have to check for this capability each time it connects to the site.

Enable Persistent Downloading.  CuteFTP will automatically reconnect and
resume in the event of an interrupted transfer.

Reconnect and resume if 0 bytes in __ seconds received.  If transfer stops for
this many seconds, CuteFTP will reconnect and resume the transfer.

After a transfer is completed.  CuteFTP can perform some self-explanatory
functions after a transfer completes.  Useful when automating transfers.

Connection � ASCII/Binary
Text (ASCII) File Extensions:  The CuteFTP program loads with several pre-

defined file extensions, but users may also define file extensions CuteFTP
should consider as ASCII (plain text) for transferring.  Note that CuteFTP
will make the final determination as to whether to transfer a file in ASCII or
Binary.

      To add additional ASCII File Extensions, click the Add button and type in the
extension, not including the dot.  To remove an ASCII File Extension, select
it from the list and click Remove.

Default transfer type:  Select the default transfer type.  Auto-detect is
recommended unless you are having problems with files being transferred
in the wrong mode.

Connection � DUN/LAN
During installation, CuteFTP detects whether your computer is connected to a
LAN or uses a modem for external communication.

To use a modem to connect:  Select Connect to the Internet using a Modem.
Choose your connection from the Use the following Dial-Up Networking
connection: field.  To activate any or all of the following optional functions,
click the check box next to the field.

Show authentication window (requires user input).  Username and password
will be checked before connection occurs.

Show error prompts (requires user interaction).  Messages indicating an
action to take will appear when errors occur.
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Disconnect from the Internet upon program exit. Your connection to the
Internet will be terminated when you exit CuteFTP.

Number of times to attempt connection:  If the connection fails, CuteFTP will
retry connecting this many more times before giving up.

Number of seconds to wait between attempts:  This indicates the delay
between connection retries.

Connection � Firewall

A firewall or proxy server is a safeguard utilized by many Local Area Networks
(LANs) or Wide Area Networks (WANs) to protect the network from unauthorized
access from the outside.  If you are using CuteFTP with a firewall or proxy
server, you may have some problems caused by the network settings.  When
you first try to use CuteFTP, leave these settings as they are and try to connect
to some of the pre-defined sites in the Site Manager.  If every site you try to
connect to prompts you with �can�t connect�, or �can�t login, still trying�, then you
probably need to configure the firewall settings.

 If your LAN or WAN supports FTP Proxy protocol, you will need the following
information:

1. IP address for your firewall host.
2. Port number for the FTP proxy server.
3. User name and password.

Enter the three items in the appropriate fields.  Select the USER user@site
radio button and the Enable Firewall Access box, then try connecting to a site.
If you still have trouble, try again with the other options (OPEN Site, etc).

The PASV Mode radio button specifies that CuteFTP will initiate all
connections and the server will only wait for requests, therefore avoiding
conflicts with the security system. NOTE: This feature is active by default.
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Custom Proxy Commands
Custom firewall type is only necessary if the predefined firewall types do not
work for you.  To use custom firewall logons, select Custom and click the
Settings button.  Define a custom logon script in the box.  The following
variables may be used:

%HOST% The address of the FTP site to connect.

%USER% Valid username for the FTP server.

%PASS% Password associated with the specified FTP
user name.

%PORT% Port used by the FTP server. If this command is not
used, it will default to 21 (the standard FTP port).

%FIRE_USER%  Firewall username. Some network configurations
may require a login for the firewall.

%FIREPASS% Password associated with the firewall username.

Example of Custom Commands:  After setting the Host and Port fields to the
correct firewall/proxy server, select the Custom option under Type, then click
Settings. Enter each command necessary to initiate an FTP session with the
remote server, one command per line. A typical series of commands might look
like this:

fire_user jimmy
fire_pass $53a&8*
host ftp.microsoft.com
user anonymous
pass somename@domain.com
port 21

This will first send the user name jimmy and the password $53a&8* to the
firewall/proxy server (as required by that specific server configuration).  Then,
CuteFTP will open a connection to the Microsoft FTP site and login
anonymously on port 21.

Contact your system administrator for the exact sequence of commands
needed.

Connection � Index Files
Users may specify masks for CuteFTP to use in identifying index files.  The
index file on the server gives you information about all the directories and files
available on that site.  Click Add in the index mask column to enter additional
masks.  You will also notice a �NOT� mask column, which tells CuteFTP which
files are not index files.  Add masks to this column in the same fashion.

If you look at the default Index Files Mask list, you will notice a file name *index*
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using Wildcards.  CuteFTP will consider any file with the word �index� in it to be
an index file.  That could cause a problem since your web page might be called
index.htm.  However, CuteFTP passes the file name through a second filter, the
Index Files NOT Mask, and sees the *htm extension in the list.  It will no longer
consider your web page as an index file because of the double filtering system.

The following options are also available:

Maximum safe index file size.  Index files larger than the specified number of
kilobytes will not be loaded automatically.  Users are prompted whether or
not to load large index files.

Auto-load index files to memory.  When enabled, any index files found will be
cached for quick accecss.

Connection � Log
The log file visible in the upper portion of the CuteFTP screen shows every
action performed and server response.  The following fields affect the session
log:

Save Logs to File.  Check this box to save log files. Click the button at the end of
the Session Log Directory field to set the path of the log file.

Start a new log file. You can specify Daily, Weekly or Monthly.  CuteFTP will
create a new log file after the specified amount of time.

Show client commands in display log. Record commands sent by CuteFTP.

Show server commands in display log. Record server messages.

Advanced INPUT command. This option is located with a right click in the log
window and allows advanced users to communicate with an FTP site at
the lowest possible level.  Advanced users might choose this when they
encounter a site with commands different from usual FTP commands (e.g.
to initiate a site-to-site transfer).

Connection � Smart Keep Alive
CuteFTP compensates for idle timeouts during sessions with the Smart Keep
Alive feature (SKA).  SKA sends commands at random intervals to the FTP
server, which maintains an active connection.

Enable Smart Keep Alive (SKA):  When checked, SKA will be active when
connected to any FTP site.

Start SKA ____ seconds after the last command. CuteFTP will begin using
SKA after the specified idle time.

Maintain SKA for ____ minutes:  CuteFTP will maintain a connection to the
FTP server for the specified length of time.

Send command at random intervals between ____ and ____ seconds:
Commands will be sent to the server using the random interval specified.
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Have SKA use these commands in random order: Click Add or Remove to
customize the commands listed. CuteFTP will issue a random command
in the list when utilizing SKA.

Enable auto-reconnect if booted from the server using a ___ second delay:
If the server terminates the connection, CuteFTP will automatically
reconnect to the FTP site.

Obtain a new IP address when reconnecting:  CuteFTP will disconnect then
reconnect to the Internet before establishing a connection to the FTP
server. Works only with dialup accounts.

Connection � Socks
If your network uses the SOCKS protocol, the following settings allow you to
connect to external FTP sites.  See also the Firewall settings for related
options.  Contact your System Administrator to obtain needed information.
NOTE:  Users also have the option not to use SOCKS for local addresses.

Use direct connection:  Select if you do NOT use the SOCKS protocol on your
network.

Socks4:  Select if your network uses the SOCKS4 protocol. You must also enter
the SOCKS Host and Port Number.

Socks5:  Select if your network uses the SOCKS5 protocol. Enter the Host and
Port Number. If Use user/password for Socks5 proxy is checked, enter
the UserID and Password supplied by your System Administrator.

Host/Port:  The host name and port number of the SOCKS proxy server.

User ID/Password:  The User ID and password for the SOCKS proxy server.

Connection � WarFTP Specific
These settings are specific to WarFTP servers. WarFTP treats PASV mode and
links differently.  CuteFTP circumvents this with the following options.

Force RFC compliant PASV mode:   Uncheck if you are having problems
connecting to WarFTP sites, or receive error messages indicating that
PASV mode is not supported.

Treat .lnk files as linked files:  .Lnk files will be treated as links instead of
directories. This solves problems with directory navigation when
connected to WarFTP sites.

Directory Navigation Settings
Default Download Directory.  Received files will be placed into this directory

unless you navigate to another directory in the local pane.

Remember the last local directory used.  The directory visible in the local
pane upon exiting CuteFTP will automatically display at the next startup.

Auto-refresh remote directory.  The contents of the remote pane are refreshed
each time you perform operations in that pane.
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Refresh after cancelled transfer.  The remote pane will be refreshed even if
your transfer is cancelled.

Symbolic Links. Symbolic links are similar to �Shortcuts� in Windows: special
files that act as pointers to other files or directories.  Users can select how
they want symbolic links displayed in the remote pane. Typically you will
want to resolve links, meaning you will see the actual file or directory in the
remote pane.

Resolve links and display L attribute.  Links are resolved and flagged with a
special L attribute.  The remote pane must be in Long Listing mode to see
file attributes.

Resolve symbolic links.  Symbolic links are resolved, but no special attribute is
set.

Do not resolve links.  The actual link files are displayed instead of the files they
point to.

Use logical parent directory.  When navigating directories using links,
CuteFTP will return to the linking directory when pressing the Parent
Directory button instead of the actual parent directory.  For example. you
are in /dir1, and double-click link zzz pointing to /dir2/subdir.  With this
option enabled, you return to /dir1 when pressing the up arrow button.
Without it, you return to /dir2.

Display  Settings
Show splash screen.  Here you can either enable or disable the CuteFTP

splash screen at startup.

Show full directory path in local pane.  The entire pathname is displayed in
the local directory pane.  If disabled, only the current folder name displays.

Show file sizes in bytes.  All file sizes are listed in bytes instead of kilobytes or
megabytes.

Auto-save sorting settings.  Remember the last used sort operation and
automatically apply it to new sessions.

Show cumulative file size in queue status bar.  A byte total for all queued files
appears in the queue window status bar.

Auto hide quick connect after each use.  The Quick Connect bar can be
made to automatically disappear after use.  If disabled, the Quick Connect
bar must be manually toggled using the Quick Connect button.

Don�t show system icons.  Instead of the regular file icons you might see in
Windows Explorer, CuteFTP will display a set of generic icons, speeding
up directory listings.

Show Text. Select this box to display text under the buttons on the Toolbar.
This is recommended if you are using a higher resolution.

Customize. Select this box to allow addition and removal of buttons on the
CuteFTP main window though the Customize Toolbar screen.  If too many
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buttons are selected, CuteFTP may not be able to display them all.

Double-click action.  Select Transfer, View, Execute, or Nothing as your default
action.  Transfer causes files in the local pane to be uploaded, and files in
the remote pane to be downloaded.  View displays the file in the Windows
Notepad.  Execute runs applications.

Display � Colors
Pane and text colors may be selected from a basic palette or custom created.

Select a basic color from the palette.  Find the pane or text field you wish to
modify.  Click the colored square next to the field name.  From the color
palette, click the basic color you wish to apply to the field then click OK.

Create a Custom Color.  Find the pane or text field you wish to modify.  Click the
colored square next to the field name.  Click the Define Custom Color
button.  Move to the new color palette (right side) to click and drag the 4-
point black cursor (usually at the top or bottom) through the color grid.
When the Color/Solid block displays the desired color, click the Add to
Custom Colors button.  Move back to the first palette under the Custom
Colors portion located at the bottom of the box, click the new color and click
OK.

Display � Fonts
Fonts for the Log window and the Programs (remote/local directory windows)
can be changed independently of one another.

To change the fonts, click the Select Font button in the Program Font box.  For
example, click the Select Font button in the Log Window Font box to change
the log window font.  Select the desired font and size from the resulting menu.

Display � Sound
Connect and end transfer sounds are audio tones played when connection to
the server occurs and when transfers are complete.  NOTE: These sounds will
only be heard if your PC has a sound card.

Users may select standard Windows sounds or use a sound file from another
source.  Select from the list the event you wish to change.  To select a default
sound, choose it from the File drop-down menu.  To choose a custom sound,
click the folder icon next to the File drop-down menu, and locate a sound file.
Click the Speaker button to preview a selected sound.

Helper Applications
CuteFTP extends its functionality using helper applications.  Two helper
applications need to be selected: a text viewer and an HTML editor.  When you
use the View or Edit functions, these helper applications are �fed� the selected
files.  To select helper applications, click the folder icon next to each field and
browse to the desired executable.

The Windows Notepad is selected as the default text viewer. CuteHTML is
automatically selected as the default HTML editor.
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Prompts
CuteFTP sends various informational messages during a session.  Note:  By
default, all message options are turned on.  To turn off message options,
deselect the check box next to the prompt you wish to turn off.

Some prompts can be turned off from the prompt dialog boxes themselves.

Overwrite Confirmation (Download/Upload).  Select this box to direct CuteFTP
to prompt you if your transfer operation is about to overwrite a file.

Automatically close prompt windows after ___ seconds. Select a default
number of seconds to display a prompt window before automatically
closing.

Transfer Binary File in ASCII Mode Warning.  Select this box to direct CuteFTP
to warn you if you are about to transfer a binary file (.exe, .wav, etc.) in ASCII
mode.

Delete Confirmation/Delete from queue confirmation. Select these boxes to
direct CuteFTP to prompt you when deleting a file or queue item.

Drag-Drop Operations Confirmation.  Select this box to direct CuteFTP to
prompt you for confirmation when you drag and drop files.

Disconnect During Transfer Confirmation.  Select this box to direct CuteFTP to
issue a warning message when you try to disconnect during a transfer.

Missing Permissions.  Select this box to direct CuteFTP to issue a prompt
when your server does not allow the operation you are attempting to
perform.

Can�t Connect to Server.  Select this box to direct CuteFTP to issue a prompt
with help functions available for connection problems.

�File unavailable� (ratio sites).  Select to enable warnings when upload/
download ratios are violated.

Prompt for user and pass when login fails.  CuteFTP will prompt for a user
and password if your login sequence fails. This can be turned off if you are
sure you have entered the correct user and pass and are being rejected by
the server due to other reasons, such as there being to many users.

Login message.  Displays the login messages sent by the FTP server.

Directory messages.  Show server messages when changing directories.

Confirm file names.  Prompts when changing file names.

Missing permissions.  Warning displayed if CHMOD is done incorrectly.
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Troubleshooting

Connection Problems
Listed below are possible connection problems and solutions.

CuteFTP can�t connect to the server / �Cannot resolve host name�

Make sure that you are connected to the Internet before you launch CuteFTP.
Select File>Site Manager and verify the host address, user name and

password.  If you are still having problems, your Web/FTP Hosting Service
can give you this information.

�Cannot resolve host name� error  for any site.

Verify that you are connected to the Internet.
Make sure that you are not mistyping the host address.

Example:  ftp://ftp.sitename.com or http://ftp.sitename.com
CuteFTP already adds the ftp:// part of your address, so just type the address.

Example:  ftp.sitename.com.

Files won�t upload or you get a �permission denied� response from the server.

Your permissions may need to be reset.  Call your web hosting server
administrator.

The file may no longer exist.  Look for the file on the server side of CuteFTP
after you connect to the site.

Insufficient credit for download�upload first.

The error message �Insufficient credit for download � upload first� is issued from
a ratio site.  Refer to the index or text file on that site for instructions on
uploading to their server.

NOTE:  Many FTP sites are run as ratio sites.  Operating under a type of file
trading system, these sites do not allow you to download a file until you have
uploaded a file or files.  Credits are issued for the uploaded files which,  in turn,
enables downloading from the site.   See Cute MP3/File Finder for more
information.

Use the queue feature of CuteFTP to make uploading to ratio sites easier and
eliminate problems with downloading files.  Add some of your files in the
queue and upload them upon connecting to the ratio site.  Consult the
administrator of the ratio site if you have any problems with the uploading
process or receiving credits.
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Frequently Asked Questions

Q) My images are uploaded, but are not displayed in my browser.

A) Any of the following may be causing your problem.

The image files were not uploaded to the server: Open CuteFTP, locate the
image files in the left window and upload them to the server. Go back to your
browser and click the reload or refresh button. The images should now be
displayed.

The image files are located on the server along with the html files, yet no
images show in the browser: When you created your web page, you set up a
path for the server to look for the image as well as the exact file name of the
image (in your .html source code). Check all paths and file names to make
sure the images are in the correct place and that the file name is correct,
including letter case. For example, the web page calls an image in the
method <IMG SRC=�my_image.gif�>, which is a common .html tag that calls
an image. To see the .html source code and all of its tags in Microsoft
Explorer, click View Source from the menu bar in the browser.  To view the
.html source code in Netscape, choose View>Page Source from the menu
bar.

Now, when you look at the file you uploaded to the server, you notice that it�s
named MY_IMAGE.GIF.  It�s upper case so the web page refers to a non-
existent image file. You need to either fix the .html code to read in upper
case: <IMG SRC=�MY_IMAGE.GIF�> or rename the file on the server to lower
case <IMG SRC=�my_image.gif�> to coordinate with the html page.

The spelling and case are an exact match,  yet your browser still doesn�t
show the images:  The .html source has a tag like this: <IMG SRC=�file://c/
Web_editor\Html\Graphics\my_image.gif�>. You check CuteFTP and on the
server side you see your image file there named my_image.gif.  When you
created your web page, the editor located the images on your hard drive�in
this case, in the C:\Web_editor\Html\Graphics subdirectory.  However, when
you uploaded the images to the server, that reference (file://c
Web_editor\Html\Graphics) is no longer a valid location for that image file.
Assuming that you uploaded that image to your virtual root directory on the
server, the <IMG SRC> tag needs to point to that location: <IMG
SRC=�my_image.gif�> or <IMG SRC=�/my_image.gif�>. You need to modify
your html file to point to the right place.

If your .html file can�t find the image in the virtual root, the file may not
actually be there. For example, you uploaded your images to a subdirectory
of the virtual root drive called Graphics and the .html IMG tag looks like this:
<IMG SRC=�my_image.gif�> Your .html file is looking to the virtual root (or /)
and doesn�t see my_image.gif there. To correct this, your IMG tag needs to
read <IMG SRC=�/Graphics/my_image.gif�>
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Q) My web pages are not showing up correctly, or not at all.

A) One of the most common mistakes is with the main page, also called the
Index. When you type in your URL or web page address, the server
automatically looks for a file in your virtual root directory called index.html,
default.html or index.htm. Make sure that your main web page is in one of these
formats. If you are not sure which format you are supposed to use, contact your
web hosting provider for assistance.

 If you did upload the file as index.html (preferably in lower case) to your virtual
root, and you still do not see anything in your browser, something else could be
causing the problem.  Sometimes a subdirectory is created beneath your
virtual root called Public_html by your ISP or service administrator. You can
see this directory in CuteFTP�s right window when you log into the server. If this
is the case, store your main web page (index.html) in that folder rather than in
the root.

For additional help with HTML, try these URLs:
http://www.htmlgoodies.com/tutors/basics.html
http://www.zdu.com.

Q) I can connect and transfer files, but the transfer rate is not satisfactory.  Also,
sometimes it starts to transfer at one speed, which decreases as the transfer
progresses. Example: The transfer rate starts at 2.5kb/s then eventually
degrades to 1.5kb/s.

A) If the connection to your FTP server is slow, it may be due to high traffic or
you may have a bad connection to your ISP.  Try to reconnect.

Q) I connect to the site, but don�t see any files or directories listed. Why?

A) There are a few possible fixes for this problem.

First, Open CuteFTP and click on Site Manager>Edit...   In the Edit Site dialog,
make sure that you are editing the site you are having problems withr. Then
click on the Advanced tab and make sure Resolve Links is unchecked.

Second, go to Site Properties. Under the General tab, select the Filter button.
Verify that there are no filters placed under FILE MASK and FILE NOT MASK.

Third, in some cases you will need to change the Host Type in the Edit Site
screen to match the type of FTP server you are connecting to.

We suggest you try all of these host types before you call technical support. If
nothing else is working and you need to see your files, there is a temporary fix
that you can set.  In the Edit Site>Advanced Tab screen, check the Simple Dir
Listing box.
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Q) How can I select multiple files for upload/download?

A) Hold down the Control or Shift keys while clicking on the file(s).

Q) I can�t configure CuteFTP to go through my firewall.

A) Ask your server administrator if the firewall supports FTP Proxy protocol. If
�yes,� then:

Determine the IP address of your firewall host and the port number of the FTP
proxy server.

The default port is 21, but they could have assigned a different port under
special circumstances. A common new user mistake when editing these
settings is to place the number 80 in the Port field just because Netscape or
Explorer has that port specified for accessing the net. Remember, FTP protocol
is not the same as HTTP protocol.

In some instances, you will also need a user name and password to bypass
your firewall.  Type these in their respective fields, then click the USER
user@site radio button and the Enable firewall access box at the bottom of
this tab.

Try again to connect to one of the pre-defined sites. Still having trouble? Go
back to the firewall tab, and click on one of the other radio buttons (USER with
logon, SITE site, OPEN site) Try to connect using each one. What about the
PASV mode check box?  It�s not recommended that you turn this feature on
unless you are experiencing problems with default settings. Default is ON.
Also, use this  setting along with the Enable firewall access box (and nothing
else) if you are having trouble displaying a directory list on a particular site.

Q) How do I configure CuteFTP to get through Wingate Proxy Server?

A) Make sure that you have enabled firewall access.  Go to the Firewall section
of the Edit>Settings window. In the Host field enter the name of the machine
running WinGate. In the Port field, enter the port number that an FTP proxy in
WinGate is configured to accept connections on. Now type in your Username
and Password (if you need one) and in the Type area enable the USER
user@site option. Choose the Enable firewall access option. The rest of the
CuteFTP settings do not relate to WinGate. When connecting to a site, make
sure the Use firewall option is enabled in the site details.

Q) How do I get WSArchie to work with CuteFTP?

A) In FTP Setup (in WSArchie) put the following text in: c:\CuteFTP\CuteFTP.exe
host=%h anonym remote=%d get=%f
Substitute �c:\CuteFTP\CuteFTP.exe� with the actual location of CuteFTP
executable file.
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Q) The http:// address I entered doesn�t work.

A) CuteFTP does not currently support HTTP. CuteFTP only supports FTP (ftp://)
addresses.

Q) CuteFTP is asking which index file would you like to load or your index file is
XXXXXXX long.  Should you load it anyway?

A) Check your settings.  CuteFTP defaults to use the Auto-Load Index Files
feature which searches for index files and automatically loads them in memory.
This feature may be disabled in the Edit/Settings window�s Index Files section.
Deselect Auto-Load Index Files.  Another setting, Max Safe Index Size,
specifies the largest index file to load without any prompts. If you do not wish to
be prompted, you may change the setting on this field to limit the number of
prompts you see or disable them completely.

Q) I am using WinNT and get a message that says: CuteFTP could not save
directory into cache.

A) This message means that CuteFTP could not locate the windows\temp
directory. Windows NT does not use the same caching setup as Windows 95 or
3.1. It may be necessary to specify a Windows temporary directory.

Q) When I upload my modified page, for instance test.html, to the server, the
server seems to receive the file, overwriting the existing test.html on the server.
However, after going to my browser and reloading the document, I still see the
old test.html, instead of the new one that I just transferred.

A) If you are editing or uploading a webpage and you do not see any changes
after it is uploaded, please try the following suggestions.

First, make sure the file that you are uploading has the same file name and
case as it appears on the remote server. If you right-clicked and selected Edit in
CuteFTP, please select File>Save to Remote after editing it in CuteHTML to
upload the file to your server.

Second, if you are still unable to see changes to your web site, clear the History
and Cache of your web browser then refresh or reload your web browser.
Whenever you visit a website your web browser will save this page as a cached
file. If you decide to visit this website again, your web browser will try to read the
information first to speed up the download and display it in your web browser.
If none of these work, contact your web host provider as they are responsible
for publishing that information.  GlobalSCAPE, Inc. does not provide web
hosting services.

Q) Is CuteFTP changing my login password?

A) CuteFTP does not change the password that you type in.  The program
displays asterisks when you enter your password to prevent onlookers from
reading your password off the screen.
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Q) How do I make CuteFTP my default FTP Browser?  I want to be able to
launch CuteFTP from the command line!

A) CuteFTP can run from the command line.  The following is an example of
how to make changes to the Windows file association.  This option varies with
each version of Windows.

Example:  To associate CuteFTP with the URL-File Transfer Protocol type in
Windows File Association Manager, go to My Computer.  Click on View then
Options.  Click on File Types, go to the file type called URL:File Transfer
Protocol and click on Edit.  Highlight Open and choose Edit.  Click on Browse
and find the CuteFTP executable and double click on it. The name of the
executable is called CutFTP32.exe.  Make sure that USE DDE is unchecked
and press OK.

Now, all you have to do is go to Start, Run, and type the FTP address you wish
to connect to, i.e. ftp.cuteftp.com. Hit Enter and CuteFTP should come up and
connect to that site. You can connect to any FTP host address you want. If you
want to connect to a password-protected FTP site, use the following syntax:  ftp://
user:pass@ftp.hostaddress.com.

Q) Why does CuteFTP come up every time I start my computer?  How can I stop
this?

A)CuteFTP is in your Startup directory. To remove it, right-click with your mouse
button on your Task Bar (the long bar that has the Start button on it).  Do not
right-click on the start button.  Now, choose Properties and click on Start Menu
Programs and then Advanced.  This will open Explorer. You should see a
Programs directory on the right-hand side.  Click there, then click the Startup
directory.  Delete anything in the startup directory that has to do with CuteFTP.

Q) How do I set up CuteFTP to go through Microsoft Proxy Server?

A)  You have several possibilities.  Go to the Firewall section of the
Edit>Settings window.  The IP address should be the IP address of the Proxy
server.  If you are unsure, contact your administrator. Next, select PASV mode.
Leave Enable Firewall Access unchecked for now.  (If you cannot connect after
this, place the check there and try again).

Check proxy server settings.  Make sure you have permissions set up for the
users (if Access Control is implemented).  Verify that MSProxy Client is
installed on respective PC�s.

For MSProxy settings help, try visiting http://proxyfaq.networkgods.com.

Q) How should I log on to my FTP Site?

A) There are two ways to log on to an FTP site. The first way is anonymous,
without user ID or password. If connecting anonymously to a site, leave the user
ID and password fields blank and check the anonymous button.  If you want to
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connect to a site your ISP (Internet Service Provider) or Web Hosting Service
has provided for you, you will need to use the host address, User ID, and
password that they provide for you.

Technical Support and Services
For the most up-to-date and accurate assistance with problems you might have
using CuteFTP, refer to CuteFTP�s Help file or our Web page at:
www.globalscape.com.

If you cannot find the answers to your questions, contact us at
support@globalscape.com, or call us at (210) 308-8267 Monday through Friday
between 8am and 6pm CST.

GlobalSCAPE Web site: www.globalscape.com

Technical support e-mail: support@globalscape.com

Technical support phone: (210) 308-8267
Hours: 8am-6pm Mon.-Fri. CST

Sales and upgrade e-mail: sales@globalscape.com
Sales and upgrade phone: (800) 290-5054

(210) 308-8267 for International Sales
Hours: 8am-6pm Mon.-Fri.
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Shortcut Keys

Depressing the Alt key allows access to the menu bar via the keyboard.  Use
the arrow keys to navigate the menus, or press the underlined letter to go
directly to that menu.  (Example: Alt-F displays the file menu.)

Key Function

Control-D Change Directory
Control-E Execute File
Control-F Find
Control-G Short Listings
Control-H Long Listings
Control-I Load Index
Control-L Filter
Control-M Make New Directory
Control-P Paste URL
Control-Q Quit CuteFTP
Control-R Reconnect
Control-U Change User
Control-V Paste
Control-W View File
Control-X Cut
Control-PgDn Download
Control-PgUp Upload
Numberpad + Group Select
Numberpad - Group Deselect
Numberpad * Invert Selection

Key Function

Delete Delete File
Backspace Directory Up
Tab Switch Browser Focus
F1 Help
F2 Rename
F3 Find Next
F4 Site Manager
Control-F4 Quick Connect
Shift-F4 Disconnect
F5 Refresh Screen
F6 Toggle Local Window
F7 Toggle Remote Window
F8 Directory Information
F9 Stop Transfer
Escape Stop Transfer
F10 Toggle Queue Window
F11 Compare Directories
F12 Toggle Log Window
Control-A Select All
Control-Shift-A Change Attributes
Control-C              Copy
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